createBlank MethodStatic
Create a new blank SpatialViewState. The returned SpatialViewState will nave non-persistent empty CategorySelectorState and ModelSelectorState, and a non-persistent DisplayStyle3dState with default values for all of its components. Generally after creating a blank SpatialViewState, callers will modify the state to suit specific needs.
createBlank(iModel: IModelConnection, origin: Readonly<WritableXYAndZ>, extents: Readonly<WritableXYAndZ>, rotation?: Matrix3d): SpatialViewState
Parameter | Type | Description |
---|---|---|
iModel | IModelConnection | The IModelConnection for the new SpatialViewState |
origin | Readonly<WritableXYAndZ> | The origin for the new SpatialViewState |
extents | Readonly<WritableXYAndZ> | The extents for the new SpatialViewState |
rotation | Matrix3d | The rotation of the new SpatialViewState. If undefined, use top view. |
Returns - SpatialViewState
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.