SpatialClassifiersState Class

The front-end representation of SpatialClassifiers that adds support for classifying a reality model using non-persistent geometry via DynamicSpatialClassifier.

@see classifiers or classifiers to access the classifiers for a particular reality model.

Extends

Inherited methods

Name Inherited from Description
[iterator](): Iterator<SpatialClassifier, any, any> Inherited SpatialClassifiers Obtain an iterator over the classifiers contained in this set.
add(classifier: SpatialClassifier): SpatialClassifier Inherited SpatialClassifiers Add a classifier to this set.
clear(): void Inherited SpatialClassifiers Remove all classifiers from this set.
delete(classifier: SpatialClassifier): undefined | SpatialClassifier Inherited SpatialClassifiers Remove the first classifier equivalent to classifier from this set.
find(criterion: (classifier: SpatialClassifier) => boolean): undefined | SpatialClassifier Inherited SpatialClassifiers Returns the first classifier that satisfies criterion, or undefined if no classifier satisfies it.
findEquivalent(classifier: SpatialClassifier): undefined | SpatialClassifier Inherited SpatialClassifiers Find the first classifier that is equivalent to the supplied classifier, or undefined if no equivalent classifier exists in this set.
has(classifier: SpatialClassifier): boolean Inherited SpatialClassifiers Return true if the specified classifier or one equivalent to it exists in this set.
replace(toReplace: SpatialClassifier, replacement: SpatialClassifier): boolean Inherited SpatialClassifiers Replace an existing classifier with a different one.
setActive(active: SpatialClassifier): undefined | SpatialClassifier Inherited SpatialClassifiers Change the active classifier.

Properties

Name Type Description
activeClassifier Accessor undefined | ActiveSpatialClassifier The classifier currently being used to classify the reality model.  

Inherited properties

Name Type Inherited from Description
active Accessor Inherited ReadOnly undefined | SpatialClassifier SpatialClassifiers The classifier currently classifying the target reality model, if any.
size Accessor Inherited ReadOnly number SpatialClassifiers The number of classifiers in this set.

Defined in

Last Updated: 14 November, 2024