createFromProps MethodStatic
Create a new ViewState object from a set of properties. Generally this is called internally by IModelConnection.Views.load after the properties have been read from an iModel. But, it can also be used to create a ViewState in memory, from scratch or from properties stored elsewhere.
createFromProps(viewStateData: ViewStateProps, iModel: IModelConnection): SheetViewState
Parameter | Type | Description |
---|---|---|
viewStateData | ViewStateProps | |
iModel | IModelConnection |
Returns - SheetViewState
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.