IconSprites Class
Icon sprites are loaded from .png files in the assets directory of imodeljs-native. They are cached by name, and the cache is cleared when the ToolAdmin is shut down.
Methods
Name | Description | |
---|---|---|
constructor(): IconSprites | ||
emptyAll(): void Static | Empty the cache, disposing all existing Sprites. | |
getSpriteFromUrl(spriteUrl: string): Sprite Static | Look up an IconSprite by url. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.