ChangeFlags Class
Describes which aspects of a Viewport have changed. Each time renderFrame is invoked, the aspects of the viewport that have changed since
the previous call to renderFrame
are computed and dispatched via the onViewportChanged event.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(flags: ChangeFlagChangeFlag.Initial): ChangeFlags | Create a new ChangeFlags. | |
areAllSet(flags: ChangeFlag): boolean | Returns true if all of the specified flags are set. | |
isSet(flags: ChangeFlag): boolean | Returns true if any of the specified flags are set. |
Properties
Name | Type | Description | |
---|---|---|---|
_flags Protected | ChangeFlag | The bitmask that records the state of each individual flag. | |
alwaysDrawn Accessor ReadOnly | boolean | The set of always-drawn elements has changed. | |
areFeatureOverridesDirty Accessor ReadOnly | boolean | Returns true if any aspects affecting Overrides have changed. | |
displayStyle Accessor ReadOnly | boolean | The DisplayStyleState or its settings such as ViewFlags have changed. | |
featureOverrideProvider Accessor ReadOnly | boolean | The FeatureOverrideProvider has changed, or its internal state has changed such that its overrides must be recomputed. | |
hasChanges Accessor ReadOnly | boolean | Returns true if any aspect at all has changed. | |
neverDrawn Accessor ReadOnly | boolean | The set of never-drawn elements has changed. | |
value Accessor ReadOnly | ChangeFlag | The underlying bitmask indicating the state of each individual flag. | |
viewedCategories Accessor ReadOnly | boolean | The set of displayed categories defined by the viewport's CategorySelectorState has changed. | |
viewedCategoriesPerModel Accessor ReadOnly | boolean | The Overrides associated with the viewport have changed. | |
viewedModels Accessor ReadOnly | boolean | The set of models to be displayed in the viewport has changed. | |
viewState Accessor ReadOnly | boolean | Vewport.changeView was used to replace the previous ViewState with a new one. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.