EditManipulator.HandleUtils Class
Utility methods for creating control handles and other decorations.
Methods
Name | Description | |
---|---|---|
constructor(): EditManipulator.HandleUtils | ||
adjustForBackgroundColor(color: ColorDef, vp: Viewport): ColorDef Static | Adjust input color for contrast against view background. | |
getArrowShape(baseStart: number0.0, baseWidth: number0.15, tipStart: number0.55, tipEnd: number1.0, tipWidth: number0.3, flangeStart: numbertipStart, flangeWidth: numberbaseWidth): Point3d[] Static | Return array of shape points representing a unit arrow in xy plane pointing in positive x direction. | |
getArrowTransform(vp: Viewport, base: Point3d, direction: Vector3d, sizeInches: number): undefined | Transform Static | Compute a transform that will try to orient a 2d shape (like an arrow) to face the camera. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.