GraphicBuilderOptions Interface
Options for creating a GraphicBuilder used by functions like createGraphic and createGraphic.
@see - ViewportGraphicBuilderOptions to create a graphic builder for a Viewport.
- CustomGraphicBuilderOptions to create a graphic builder unassociated with any Viewport.
Properties
Name | Type | Description | |
---|---|---|---|
generateEdges | boolean | undefined | Controls whether edges are generated for surfaces. | |
pickable | PickableGraphicOptions | undefined | If the graphic is to be pickable, specifies the pickable Id and other options. | |
placement | Transform | undefined | The local-to-world transform in which the builder's geometry is to be defined - by default, an identity transform. | |
preserveOrder | boolean | undefined | If true, the order in which geometry is added to the builder is preserved. | |
type | GraphicType | The type of graphic to produce. | |
viewIndependentOrigin | Point3d | undefined | If defined, specifies a point about which the graphic will rotate such that it always faces the viewer. | |
wantNormals | boolean | undefined | Controls whether normals are generated for surfaces. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.