ImageryMapLayerFormat Class
Base class imagery map layer formats. Subclasses should override formatId and createImageryProvider.
@see MapLayerFormat
Extends
Methods
Name | Description | |
---|---|---|
constructor(): ImageryMapLayerFormat |
Inherited methods
Name | Inherited from | Description |
---|---|---|
createImageryProvider(_settings: MapLayerSettings): undefined | MapLayerImageryProvider Static Inherited | MapLayerFormat | Create a MapLayerImageryProvider that will be used to feed data in a map-layer tile tree. |
register(): void Static Inherited | MapLayerFormat | Register the current format in the MapLayerFormatRegistry. |
validate(args: ValidateSourceArgs): Promise<MapLayerSourceValidation> Static Inherited | MapLayerFormat | Allow a source object to be validated before being attached as a map-layer. |
validateSource(_url: string, _userName?: string, _password?: string, _ignoreCache?: boolean, _accesKey?: MapLayerKey): Promise<MapLayerSourceValidation> Static Inherited | MapLayerFormat | Allow a source of a specific format to be validated before being attached as a map-layer. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
formatId Static Inherited | string | MapLayerFormat |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.