HitDetailProps Interface
Arguments supplied to the HitDetail constructor.
Properties
Name | Type | Description | |
---|---|---|---|
distFraction Readonly | number | The distance in view coordinates between the hit and the near plane. | |
distXY Readonly | number | The xy distance to the hit in view coordinates. | |
geometryClass Readonly | GeometryClass | undefined | The class of the hit geometry. | |
hitPoint Readonly | Point3d | The approximate location in world coordinates on the geometry identified by this HitDetail. | |
hitSource Readonly | HitSource | The procedure that requested the locate operation. | |
modelId Readonly | string | undefined | The Id of the ModelState from which the hit originated. | |
path Readonly | HitPath | undefined | Describes the path by which the hit was located through a series of attached views. | |
priority Readonly | HitPriority | The hit geometry priority/classification. | |
sourceId Readonly | string | The source of the geometry. | |
subCategoryId Readonly | string | undefined | The SubCategory to which the hit geometry belongs. | |
testPoint Readonly | Point3d | The point in world coordinates that was used as the initial locate point. | |
viewport Readonly | ScreenViewport | The viewport in which the locate operation was performed. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.