doSnapRequest Method
Request a snap from the backend for the supplied HitDetail.
doSnapRequest(hit: HitDetail, snapMode?: SnapMode): Promise<undefined | SnapDetail>
@returns A Promise for the SnapDetail or undefined if no snap could be created.
Parameter | Type | Description |
---|---|---|
hit | HitDetail | The HitDetail to snap to. |
snapMode | SnapMode | Optional SnapMode, uses active snap modes if not specified. |
Returns - Promise<undefined | SnapDetail>
A Promise for the SnapDetail or undefined if no snap could be created.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.