BriefcaseNotificationHandler Class
Base class for notification handlers for events from the backend that are specific to a BriefcaseConnection.
@see BriefcaseTxns.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(_key: string): BriefcaseNotificationHandler |
Inherited methods
Name | Inherited from | Description |
---|---|---|
registerImpl(): RemoveFunction | NotificationHandler | |
register(): RemoveFunction Static | NotificationHandler | Register this class as the handler for notifications on its channel. |
Properties
Name | Type | Description | |
---|---|---|---|
briefcaseChannelName Accessor Abstract ReadOnly | string | ||
channelName Accessor ReadOnly | string | All subclasses must implement this method to specify their response channel name. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.