getSnapRotation MethodStatic
Return a Matrix3d from a SnapDetail. Uses SnapDetail.normal and primitive when available to create the most well defined rotation for the given snap location.
getSnapRotation(snap: SnapDetail, matrix?: Matrix3d): undefined | Matrix3d
Parameter | Type | Description |
---|---|---|
snap | SnapDetail | |
matrix | Matrix3d |
Returns - undefined | Matrix3d
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.