ViewStoreRpc.AddViewArgs Interface

Arguments for adding a new view to a ViewStore.

Properties

Name Type Description
categorySelectorProps Readonly CategorySelectorProps | undefined The properties of a category selector for the new view.  
displayStyleProps Readonly DisplayStyleProps | undefined The properties of a display style for the new view.  
group Readonly string | undefined    
isPrivate Readonly boolean | undefined    
modelSelectorProps Readonly ModelSelectorProps | undefined The properties of a model selector for the new view.  
owner Readonly string | undefined    
tags Readonly string[] | undefined    
thumbnail Readonly ThumbnailProps | undefined optional thumbnail for the view.  
viewDefinition Readonly ViewDefinitionProps the properties of the ViewDefinition for the new view.  

Defined in

Last Updated: 14 November, 2024