ContourGroup Class

Defines a group of objects to which to apply Contour lines in a particular style. The ContourDisplay settings can contain multiple groups. Each group is described by a set of SubCategory's; all geometry belonging to any of those subcategories belongs to the group. An empty set of subcategories indicates that this is a default group, implicitly containing all subcategories that are not explicitly included in another group. Each group has an optional, non-user-facing name that applications can use to assign semantics to particular groups.

Methods

Name Description
clone(changedProps?: Partial<ContourGroupProperties>): ContourGroup Create a copy of this ContourGroup, identical except for any properties specified by changedProps.  
equals(other: ContourGroup): boolean Returns true if this and other are logically equivalent, having the same styling, name, and set of subcategories.  
subCategoriesEqual(other: ContourGroup): boolean Returns true if this and other contain the exact same set of subcategories.  
toJSON(): ContourGroupProps    
create(props?: Partial<ContourGroupProperties>): ContourGroup Static Create a new ContourGroup.  
fromJSON(props?: ContourGroupProps): ContourGroup Static    

Properties

Name Type Description
contourDef Readonly Contour Describes the appearance of all of the contours applied to geometry belonging to this group.  
isDefaultGroup Accessor ReadOnly boolean Returns true if subCategories is an empty set, indicating that any subcategory not included in any other ContourGroup is implicitly  
name Readonly string An optional, non-user-facing name that applications can use to assign semantics to particular groups.  
subCategories Accessor ReadOnly OrderedId64Iterable The set of subcategories belonging to this group, or an empty set if this is a default group.  

Defined in

Last Updated: 14 November, 2024