ContourDisplay Class
Settings that specify how to apply contour lines to groups of geometry within a 3d scene.
@see contours to associate contour settings with a display style.
Methods
Name | Description | |
---|---|---|
clone(changedProps?: Partial<ContourDisplayProperties>): ContourDisplay | Create a copy of this ContourDisplay, identical except for any properties specified by changedProps . |
|
equals(other: ContourDisplay): boolean | Returns true if this and other are logically equivalent, having the same groups and styling. |
|
toJSON(): ContourDisplayProps | ||
withDisplayContours(displayContours: boolean): ContourDisplay | Create a copy of these settings, changing the displayContours flag as specified. |
|
create(props?: Partial<ContourDisplayProperties>): ContourDisplay Static | Create a new ContourDisplay. | |
fromJSON(props?: ContourDisplayProps): ContourDisplay Static |
Properties
Name | Type | Description | |
---|---|---|---|
displayContours Readonly | boolean | Whether to display the contour lines described by these settings. | |
groups Readonly | ContourGroup[] | A list of the groups, each describing their own specific contour display settings. | |
maxContourGroups Static Readonly | "5" | The maximum number of contour groups that the system will allow. |
Defined in
- core/common/src/ContourDisplay.ts Line 381
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.