RenderTexture.Params Class
Deprecated in 3.x. use RenderSystem.createTexture and CreateTextureArgs.
Parameters used to construct a RenderTexture.
Methods
Name | Description | |
---|---|---|
constructor(key?: string, type: RenderTexture.TypeRenderTexture.Type.Normal, isOwned: booleanfalse): RenderTexture.Params |
Properties
Name | Type | Description | |
---|---|---|---|
isGlyph Accessor ReadOnly | boolean | ||
isOwned Readonly | boolean | Indicates that some object is managing the lifetime of this texture and will take care of calling its dispose function appropriately. | |
isSkyBox Accessor ReadOnly | boolean | ||
isTileSection Accessor ReadOnly | boolean | ||
key Readonly | string | undefined | A string uniquely identifying this texture within the context of an IModel. | |
type Readonly | RenderTexture.Type | Indicates the type of texture. |
Defined in
- core/common/src/RenderTexture.ts Line 76
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.