OverrideSubCategoryAppearanceOptions Interface
Options for using override to override the appearance of a SubCategory.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
subCategoryId | string | The Id of the subcategory whose appearance is to be overridden. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
appearance | FeatureAppearance | OverrideFeatureAppearanceOptions | Specifies the aspects of the Feature's appearance to be overridden. |
onConflict | "extend" | "replace" | "subsume" | "skip" | OverrideFeatureAppearanceOptions | Specifies what to do if a FeatureAppearance has already been configured for the specified element, model, or subcategory by a previous call to override. |
Defined in
- core/common/src/FeatureSymbology.ts Line 357
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.