clone Method
Create a copy of this appearance, overriding any properties explicitly specified by changedProps
.
Example:
const base = FeatureAppearance.fromRgba(ColorDef.white); // transparency=0, rgb=white
const clone = base.clone({ transparency: undefined, weight: 5 }); // transparency=undefined, rgb=white, weight=5
clone(changedProps: FeatureAppearanceProps): FeatureAppearance
@see cloneProps.
Parameter | Type | Description |
---|---|---|
changedProps | FeatureAppearanceProps |
Returns - FeatureAppearance
Defined in
- core/common/src/FeatureSymbology.ts Line 210
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.