FeatureAppearanceProps Interface

JSON representation of a FeatureAppearance.

Properties

Name Type Description
emphasized "true" | undefined See emphasized.  
ignoresMaterial "true" | undefined See ignoresMaterial.  
linePixels LinePixels | undefined See linePixels.  
lineRgb "false" | RgbColorProps See lineRgb.  
lineTransparency number | "false" See lineTransparency.  
nonLocatable "true" | undefined See nonLocatable.  
rgb RgbColorProps | undefined See FeatureAppearance.rgb.  
transparency number | undefined See transparency.  
viewDependentTransparency "true" | undefined See viewDependentTransparency.  
weight number | undefined See FeatureAppearance.weight.  

Defined in

Last Updated: 14 November, 2024