Projection Class
This class encapsulates the projection of the CRS. The projection relies on a projection method and a set of projection parameters specific to projection method selected to flatten the surface of the model of the Earth defines as a geodetic ellipsoid. The flattening and the distortion angular, linear, scale from the process varies between methods. Refer to appropriate external documentation for details.
@note Various property sets are required for specific projection methods. The current class implementation does not enforce these rules yet and it is possible to define or not define any property regardless the method used.
Implements
Methods
Name | Description | |
---|---|---|
constructor(_data?: ProjectionProps): Projection | ||
equals(other: Projection): boolean | Compares two projections. | |
toJSON(): ProjectionProps | Creates a JSON from the Projection definition | |
fromJSON(data: ProjectionProps): Projection Static | Creates a Projection from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
affine Readonly | AffineTransform | undefined | The definition of the affine post-transformation for Transverse Mercator and Lambert Conformal Conic with post-affine projections | |
azimuth Readonly | number | undefined | Azimuth. | |
centralMeridian Readonly | number | undefined | The Central Meridian. | |
centralPointLatitude Readonly | number | undefined | Latitude of the central point. | |
centralPointLongitude Readonly | number | undefined | Longitude of the central point. | |
danishSystem34Region Readonly | DanishSystem34Region | undefined | The Danish zone for Danish projections. | |
elevationAboveGeoid Readonly | number | undefined | The elevation of the origin of the projection above the geoid. | |
falseEasting Readonly | number | undefined | The False Easting of the projection. | |
falseNorthing Readonly | number | undefined | The False Northing of the projection. | |
geoidSeparation Readonly | number | undefined | The geoid separation. | |
hemisphere Readonly | HemisphereEnum | undefined | The hemisphere for Universal Transverse Mercator projection. | |
latitudeOfOrigin Readonly | number | undefined | The latitude of origin of the projection. | |
longitudeOfOrigin Readonly | number | undefined | Longitude of origin of the projection. | |
method Readonly | ProjectionMethod | The projection method. | |
point1Latitude Readonly | number | undefined | Latitude of the first alignment point for some Oblique Mercator and Krovak projections. | |
point1Longitude Readonly | number | undefined | Longitude of the first alignment point for some Oblique Mercator and Krovak projections. | |
point2Latitude Readonly | number | undefined | Latitude of the second alignment point for some Oblique Mercator projections. | |
point2Longitude Readonly | number | undefined | Longitude of the second alignment point for some Oblique Mercator projections. | |
scaleFactor Readonly | number | undefined | The scale reduction factor applied at origin. | |
standardParallel Readonly | number | undefined | Standard parallel for projection that only use one. | |
standardParallel1 Readonly | number | undefined | The first standard parallel at which the cone crosses the ellipsoid. | |
standardParallel2 Readonly | number | undefined | The second standard parallel at which the cone crosses the ellipsoid. | |
zoneNumber Readonly | number | undefined | The UTM zone number. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.