GeometryStreamIteratorEntry Interface
Holds current state information for GeometryStreamIterator. Each entry represents exactly one geometry primitive in the stream.
Properties
Name | Type | Description | |
---|---|---|---|
geomParams Readonly | GeometryParams | A GeometryParams representing the appearance of the current geometric entry | |
localRange Readonly | Range3d | undefined | Optional stored local range for the current geometric entry | |
localToWorld Readonly | Transform | undefined | Placement transform, used for converting placement relative, local coordinate entries to world | |
primitive Readonly | GeometryStreamPrimitive | Returns the geometric primitive represented by this entry. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.