fromGeometricElement2d MethodStatic
Create a new GeometryStream iterator for a GeometricElement2d. If placement is not undefined, placement relative entries will be returned transformed to world coordinates.
fromGeometricElement2d(element: Pick<GeometricElement2dProps, "geom" | "placement" | "category">): GeometryStreamIterator
@throws IModelError if element.geom is undefined.
Parameter | Type | Description |
---|---|---|
element | Pick<GeometricElement2dProps, "geom" | "placement" | "category"> |
Returns - GeometryStreamIterator
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.