transformBy Method

Applies the specified transformation matrix to produce a new bounding sphere.

transformBy(transform: Transform, result?: BoundingSphere): BoundingSphere

@returns A bounding sphere equivalent to this with the specified transform applied.

Parameter Type Description
transform Transform The transformation matrix to apply.
result BoundingSphere An optional preallocated object to hold the result, to avoid allocating a new object. May be the same object as this.

Returns - BoundingSphere

A bounding sphere equivalent to this with the specified transform applied.

Defined in

Last Updated: 14 November, 2024