SectionDrawingLocationProps Interface
Properties that define a SectionDrawingLocation
Extends
Properties
Name | Type | Description | |
---|---|---|---|
sectionView | RelatedElementProps | undefined | The ViewDefinition to which this location refers. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category | string | GeometricElement3dProps | The id of the category for this geometric element. |
classFullName | string | GeometricElement3dProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | GeometricElement3dProps | The Code for this element |
elementGeometryBuilderParams | ElementGeometryBuilderParams | undefined | GeometricElement3dProps | Describes how to build the element's GeometryStream, as an alternative to geom. |
federationGuid | string | undefined | GeometricElement3dProps | A FederationGuid assigned to this element. |
geom | GeometryStreamProps | undefined | GeometricElement3dProps | The geometry stream properties |
id | string | undefined | GeometricElement3dProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | GeometricElement3dProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties | any | undefined | GeometricElement3dProps | Optional json properties of this element. |
model | string | GeometricElement3dProps | The Id of the Model containing this element |
parent | RelatedElementProps | undefined | GeometricElement3dProps | The Parent of this element, if defined. |
placement | Placement3dProps | undefined | GeometricElement3dProps | The placement properties |
typeDefinition | RelatedElementProps | undefined | GeometricElement3dProps | |
userLabel | string | undefined | GeometricElement3dProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 226
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.