clone Method
Create a copy of this TerrainSettings, optionally modifying some of its properties.
clone(changedProps?: TerrainProps): TerrainSettings
@returns A TerrainSettings with all of its properties set to match those ofthis
, except those explicitly defined in changedProps
.
Parameter | Type | Description |
---|---|---|
changedProps | TerrainProps | JSON representation of the properties to change. |
Returns - TerrainSettings
A TerrainSettings with all of its properties set to match those ofthis
, except those explicitly defined in changedProps
.
Defined in
- core/common/src/TerrainSettings.ts Line 191
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.