RenderSchedule.ScriptBuilder Class
Assembles the JSON representation for a new RenderSchedule.Script. Ensure that entries on any given element timeline are added chronologically. As an extremely simple example, the following code produces a script that changes the color of a single element:
const script = new ScriptBuilder();
const model = script.addModelTimeline("0x123");
const element = model.addElementTimeline([ "0x456" ]);
element.addColor(Date.now(), new RgbColor(0xff, 0x7f, 0));
const scriptProps = script.finish();
Methods
Name | Description | |
---|---|---|
constructor(): RenderSchedule.ScriptBuilder | ||
addModelTimeline(modelId: string): RenderSchedule.ModelTimelineBuilder | Add a new ModelTimeline to be applied to the specified model. | |
finish(): RenderSchedule.ScriptProps | Obtain the JSON representation of the RenderSchedule.Script produced by this builder. |
Defined in
- core/common/src/RenderSchedule.ts Line 1443
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.