clone Method
Create a copy of these light settings, identical except for any properties explicitly specified by changed
.
Note that the solar, ambient, and hemisphere lights will also be cloned using their own clone
methods - so for example, the following:
clone({ ambient: { intensity: 0.5 } })
will overwrite the ambient light's intensity but preserve its current color, rather than replacing the color with the default color.
clone(changed?: LightSettingsProps): LightSettings
Parameter | Type | Description |
---|---|---|
changed | LightSettingsProps |
Returns - LightSettings
Defined in
- core/common/src/LightSettings.ts Line 502
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.