Environment Class
As part of a DisplayStyle3dSettings, controls the display of a SkyBox and GroundPlane to simulate the outdoor environment.
@see environment.
Methods
Name | Description | |
---|---|---|
constructor(props?: Partial<EnvironmentProperties>): Environment Protected | ||
clone(changedProps?: Partial<EnvironmentProperties>): Environment | Create a copy of this environment, identical except for any properties specified by changedProps . |
|
toJSON(): EnvironmentProps | Convert to JSON representation. | |
withDisplay(display: { atmosphere?: boolean, ground?: boolean, sky?: boolean }): Environment | Create a copy of this environment, changing the displayGround , displaySky and/or displayAtmosphere flags. |
|
create(props?: Partial<EnvironmentProperties>): Environment Static | Create a new Environment. | |
fromJSON(props?: EnvironmentProps): Environment Static | Create from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
atmosphere Readonly | Atmosphere.Settings | Describes how the atmosphere should be drawn | |
defaults Static Readonly | Environment | Default settings without a ground plane, sky box, or atmosphere displayed. | |
displayAtmosphere Readonly | boolean | If true, the atmosphere will be displayed. | |
displayGround Readonly | boolean | If true, the ground plane will be displayed. | |
displaySky Readonly | boolean | If true, the sky box will be displayed. | |
ground Readonly | GroundPlane | Describes how the ground plane should be drawn. | |
sky Readonly | SkyBox | Describes how the sky box should be drawn. |
Defined in
- core/common/src/Environment.ts Line 39
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.