AmbientOcclusion.Settings Class
Describes the properties with which ambient occlusion should be drawn. These properties correspond to a horizon-based ambient occlusion approach.
Implements
Methods
Name | Description | |
---|---|---|
toJSON(): AmbientOcclusion.Props | ||
fromJSON(json?: AmbientOcclusion.Props): AmbientOcclusion.Settings Static |
Properties
Name | Type | Description | |
---|---|---|---|
bias Readonly | number | If defined, represents an angle in radians. | |
blurDelta Readonly | number | If defined, blurDelta is used to compute the weight of a Gaussian filter. | |
blurSigma Readonly | number | If defined, blurSigma is used to compute the weight of a Gaussian filter. | |
blurTexelStepSize Readonly | number | ||
defaults Static | AmbientOcclusion.Settings | ||
intensity Readonly | number | If defined, raise the final ambient occlusion to the power of this value. | |
maxDistance Readonly | number | If defined, the maximum distance from the camera's near plane in meters at which ambient occlusion will be applied. | |
texelStepSize Readonly | number | If defined, indicates the texel distance to step toward the next texel sample in the current direction. | |
zLengthCap Readonly | number | If defined, if the distance in linear depth from the current sample to first sample is greater than this value, sampling stops in the current direction. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.