computeTransform Method
Compute the transform that positions and orients this annotation relative to its anchor point, based on the textBlock's computed bounding box.
The anchor point is computed as specified by this annotation's anchor setting. For example, if the text block is anchored
at the bottom left, then the transform will be relative to the bottom-left corner of textBlockExtents
.
The text block will be rotated around the fixed anchor point according to orientation, then translated by offset.
The anchor point will coincide with (0, 0, 0).
computeTransform(boundingBox: Range2d): Transform
@see computeAnchorPoint to compute the transform's anchor point.
Parameter | Type | Description |
---|---|---|
boundingBox | Range2d | A box fully containing the textBlock. |
Returns - Transform
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.