RunLayoutResult Interface
Represents a single run in a LineLayoutResult.
@note Get the text content of the RunLayoutResult using a combination of the sourceRunIndex
, characterOffset
, and characterCount
.
Properties
Name | Type | Description | |
---|---|---|---|
characterCount | number | The number of characters in the RunLayoutResult. | |
characterOffset | number | The number of characters from the source Run that have already appeared in the layout. | |
denominatorRange | Range2dProps | undefined | The range containing the contents of the FractionRun's denominator. | |
fontId | number | The ID of the font for the run. | |
justificationRange | Range2dProps | undefined | Bounding box used when justifying the run. | |
numeratorRange | Range2dProps | undefined | The range containing the contents of the FractionRun's numerator. | |
offsetFromLine | Readonly<WritableXAndY> | The offset of the RunLayoutResult from the top and left of the LineLayoutResult | |
range | Range2dProps | Bounding box enclosing this RunLayoutResult's content. | |
sourceRunIndex | number | The index of the Run this RunLayoutResult was generated from in Paragraph.runs. | |
textStyle | TextStyleSettingsProps | The TextStyleSettings for the run. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.