TextStyleSettingsProps Interface
Serves both as the JSON representation of a TextStyleSettings, and a way for a TextBlockComponent to selectively override aspects of a TextStyle's properties.
Properties
Name | Type | Description | |
---|---|---|---|
color | TextStyleColor | undefined | The color of the text. | |
fontName | string | undefined | The name of a font stored in a Workspace, used to draw the contents of a TextRun. | |
isBold | boolean | undefined | Specifies whether the content of a TextRun should be rendered bold. | |
isItalic | boolean | undefined | Specifies whether the content of a TextRun should be rendered in italics. | |
isUnderlined | boolean | undefined | Specifies whether the content of a TextRun should be underlined. | |
lineHeight | number | undefined | The height each line of text, in meters. | |
lineSpacingFactor | number | undefined | Multiplier used to compute the vertical distance between two lines of text. | |
stackedFractionScale | number | undefined | Multiplier used to compute the height of both the numerator and denominator of a FractionRun. | |
stackedFractionType | StackedFractionType | undefined | Specifies how to separate the numerator and denominator of a FractionRun. | |
subScriptOffsetFactor | number | undefined | Multiplier used to compute the vertical offset from the baseline for a subscript TextRun. | |
subScriptScale | number | undefined | Multiplier used to compute the height of a subscript TextRun. | |
superScriptOffsetFactor | number | undefined | Multiplier used to compute the vertical offset from the baseline for a super TextRun. | |
superScriptScale | number | undefined | Multiplier used to compute the height of a superscript TextRun. | |
widthFactor | number | undefined | A scale applied to the width of each glyph. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.