addListener Method
Registers a Listener to be executed whenever this event is raised.
addListener(listener: T, scope?: any): () => void
@returns A function that will remove this event listener.
@see raiseEvent, removeListener
Parameter | Type | Description |
---|---|---|
listener | T | The function to be executed when the event is raised. |
scope | any | An optional object scope to serve as the 'this' pointer when listener is invoked. |
Returns - () => void
A function that will remove this event listener.
Defined in
- core/bentley/src/BeEvent.ts Line 42
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.