Uint16ArrayBuilder Class
A TypedArrayBuilder for producing a Uint16Array.
Extends
- TypedArrayBuilder<Uint16Array>
Methods
Name | Description | |
---|---|---|
constructor(options?: TypedArrayBuilderOptions): Uint16ArrayBuilder | See TypedArrayBuilder constructor. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
append(values: Uint16Array): void Inherited | TypedArrayBuilder<Uint16Array> | Append an array of values, resizing (at most once) if necessary. |
at(index: number): number Inherited | TypedArrayBuilder<Uint16Array> | Like TypedArray.at, |
ensureCapacity(newCapacity: number): number Inherited | TypedArrayBuilder<Uint16Array> | Ensure that capacity is at least equal to newCapacity . |
push(value: number): void Inherited | TypedArrayBuilder<Uint16Array> | Append the specified value, resizing if necessary. |
toTypedArray(includeUnusedCapacity: booleanfalse): Uint16Array Inherited | TypedArrayBuilder<Uint16Array> | Obtain the finished array. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_constructor Protected Inherited | Constructor<Uint16Array> | TypedArrayBuilder<Uint16Array> | The constructor for the specific type of array being populated. |
_data Protected Inherited | Uint16Array | TypedArrayBuilder<Uint16Array> | The underlying typed array, to be reallocated and copied when its capacity is exceeded. |
_length Protected Inherited | number | TypedArrayBuilder<Uint16Array> | The number of elements added to the array so far. |
capacity Accessor Inherited ReadOnly | number | TypedArrayBuilder<Uint16Array> | The number of elements that can fit into the memory currently allocated for the array. |
growthFactor Readonly Inherited | number | TypedArrayBuilder<Uint16Array> | Multiplier applied to required capacity by ensureCapacity. |
length Accessor Inherited ReadOnly | number | TypedArrayBuilder<Uint16Array> | The number of elements currently in the array. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.