IndexMap<T> Class
Maintains a set of unique elements in sorted order and retains the insertion order of each. The uniqueness of the elements is determined by a comparison routine supplied by the user. The user may also supply a maximum size, beyond which insertions will fail.
Methods
Name | Description | |
---|---|---|
constructor<T>(compare: OrderedComparator<T>, maximumSize: numberNumber.MAX_SAFE_INTEGER, clone: CloneFunction<T>shallowClone): IndexMap<T> | Construct a new IndexMap |
|
clear(): void | Removes all elements from the map. | |
indexOf(value: T): number | Finds the index of an element equivalent to the supplied value. | |
insert(value: T, onInsert?: (value: T) => any): number | Attempt to insert a new value into the map. | |
lowerBound(value: T): { equal: boolean, index: number } Protected | ||
toArray(): T[] | Return an array of the elements in this map in which the array index of each element corresponds to the index assigned to it by the map. |
Properties
Name | Type | Description | |
---|---|---|---|
_array Protected | IndexedValue<T>[] | ||
_clone Protected Readonly | CloneFunction<T> | ||
_compareValues Protected Readonly | OrderedComparator<T> | ||
_maximumSize Protected Readonly | number | ||
isEmpty Accessor ReadOnly | boolean | Returns true if the map contains no elements. | |
isFull Accessor ReadOnly | boolean | Returns true if the maximum number of elements have been inserted. | |
length Accessor ReadOnly | number | The number of elements in the map. |
Defined in
- core/bentley/src/IndexMap.ts Line 31
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.