create MethodStatic
Create an OrthographicViewDefinition
create(iModelDb: IModelDb, definitionModelId: string, name: string, modelSelectorId: string, categorySelectorId: string, displayStyleId: string, range: Range3d, standardView: StandardViewIndexStandardViewIndex.Iso): OrthographicViewDefinition
@returns The newly constructed OrthographicViewDefinition element
@throws IModelError if there is a problem creating the view
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The iModel |
definitionModelId | string | The DefinitionModel |
name | string | The name/CodeValue of the view |
modelSelectorId | string | The ModelSelector that this view should use |
categorySelectorId | string | The CategorySelector that this view should use |
displayStyleId | string | The DisplayStyle3d that this view should use |
range | Range3d | Defines the view origin and extents |
standardView | StandardViewIndex | Optionally defines the view's rotation |
Returns - OrthographicViewDefinition
The newly constructed OrthographicViewDefinition element
Defined in
- core/backend/src/ViewDefinition.ts Line 439
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.