create MethodStatic
Create a DrawingViewDefinition
create(iModelDb: IModelDb, definitionModelId: string, name: string, baseModelId: string, categorySelectorId: string, displayStyleId: string, range: Range2d): DrawingViewDefinition
@throws IModelError if there is a problem creating the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The iModel |
definitionModelId | string | The DefinitionModel |
name | string | The name/CodeValue of the view |
baseModelId | string | The base DrawingModel |
categorySelectorId | string | The CategorySelector that this view should use |
displayStyleId | string | The DisplayStyle2d that this view should use |
range | Range2d | Defines the view origin and extents |
Returns - DrawingViewDefinition
Defined in
- core/backend/src/ViewDefinition.ts Line 554
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.