insert MethodStatic
Insert a DisplayStyle3d for use by a ViewDefinition.
insert(iModelDb: IModelDb, definitionModelId: string, name: string, options?: DisplayStyleCreationOptions): string
@returns The Id of the newly inserted DisplayStyle3d element.
@throws IModelError if unable to insert the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
definitionModelId | string | Insert the new DisplayStyle3d into this DefinitionModel |
name | string | The name of the DisplayStyle3d |
options | DisplayStyleCreationOptions |
Returns - string
The Id of the newly inserted DisplayStyle3d element.
Defined in
- core/backend/src/DisplayStyle.ts Line 313
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.