DisplayStyleCreationOptions Interface
Describes initial settings for a new DisplayStyle3d. Most properties are inherited from DisplayStyle3dSettingsProps, but for backwards compatibility reasons, this interface is slightly awkward:
- It adds a
viewFlags
member that differs only in case and type from DisplayStyleSettingsProps.viewflags; and - It extends the type of DisplayStyleSettingsProps.backgroundColor to include ColorDef. These idiosyncrasies will be addressed in a future version of core-backend.
@see DisplayStyle3d.create.
Extends
- Omit<DisplayStyle3dSettingsProps, "backgroundColor" | "scheduleScript">
Properties
Name | Type | Description | |
---|---|---|---|
backgroundColor | number | ColorDef | ||
viewFlags | ViewFlags | undefined | If supplied, the ViewFlags applied by the display style. |
Defined in
- core/backend/src/DisplayStyle.ts Line 183
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.