create MethodStatic
Create a DisplayStyle3d for use by a ViewDefinition.
create(iModelDb: IModelDb, definitionModelId: string, name: string, options?: DisplayStyleCreationOptions): DisplayStyle3d
@returns The newly constructed DisplayStyle3d element.
@throws IModelError if unable to create the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The iModel |
definitionModelId | string | The DefinitionModel |
name | string | The name/CodeValue of the DisplayStyle3d |
options | DisplayStyleCreationOptions |
Returns - DisplayStyle3d
The newly constructed DisplayStyle3d element.
Defined in
- core/backend/src/DisplayStyle.ts Line 280
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.