SynchronizationConfigSpecifiesRootSources Class
Relates a SynchronizationConfigLink to root ExternalSource instances.
@note The associated ECClass was added to the BisCore schema in version 1.0.13
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: RelationshipProps, iModel: IModelDb): SynchronizationConfigSpecifiesRootSources Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited | SynchronizationConfigProcessesSources | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void Inherited | SynchronizationConfigProcessesSources | Delete this Relationship from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited | SynchronizationConfigProcessesSources | Call a function for each property of this Entity. |
getReferenceIds(): EntityReferenceSet Inherited | SynchronizationConfigProcessesSources | Get the set of this entity's entity references, EntityReferenceSet. |
insert(): string Inherited | SynchronizationConfigProcessesSources | Insert this Relationship into the iModel. |
toJSON(): RelationshipProps Inherited | SynchronizationConfigProcessesSources | Obtain the JSON representation of this Entity. |
update(): void Inherited | SynchronizationConfigProcessesSources | Update this Relationship in the iModel. |
create<T extends ElementRefersToElements>(iModel: IModelDb, sourceId: string, targetId: string): T Static Inherited | SynchronizationConfigProcessesSources | Create an instance of the Relationship. |
getInstance<T extends Relationship>(iModel: IModelDb, criteria: string | SourceAndTarget): T Static Inherited | SynchronizationConfigProcessesSources | |
insert<T extends ElementRefersToElements>(iModel: IModelDb, sourceId: string, targetId: string): string Static Inherited | SynchronizationConfigProcessesSources | Insert a new instance of the Relationship. |
is(otherClass: ): boolean Static Inherited | SynchronizationConfigProcessesSources | return whether this Entity class is a subclass of another Entity class |
onDeletedDependency(_props: RelationshipProps, _iModel: IModelDb): void Static Inherited | SynchronizationConfigProcessesSources | Callback invoked by saveChanges on an ElementDrivesElement relationship when the relationship instance has been deleted. |
onRootChanged(_props: RelationshipProps, _iModel: IModelDb): void Static Inherited | SynchronizationConfigProcessesSources | Callback invoked by saveChanges on an ElementDrivesElement relationship when its input has changed or is the output of some upstream relationship whose input has changed. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Inherited ReadOnly | string | SynchronizationConfigProcessesSources | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly | string | SynchronizationConfigProcessesSources | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly | string | SynchronizationConfigProcessesSources | The name of the BIS class associated with this class. |
id Inherited | string | SynchronizationConfigProcessesSources | The Id of this Entity. |
iModel Inherited | IModelDb | SynchronizationConfigProcessesSources | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited | "true" | SynchronizationConfigProcessesSources | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static Inherited | SynchronizationConfigProcessesSources | The Schema that defines this class. | |
schemaName Accessor Inherited ReadOnly | string | SynchronizationConfigProcessesSources | The name of the BIS Schema that defines this class |
sourceId Readonly Inherited | string | SynchronizationConfigProcessesSources | |
targetId Readonly Inherited | string | SynchronizationConfigProcessesSources |
Defined in
- core/backend/src/Relationship.ts Line 125
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.