Relationship Class
Base class for all link table ECRelationships
Extends
Extended by
Methods
Name |
Description |
|
constructor(props: RelationshipProps, iModel: IModelDb): Relationship Protected |
|
|
delete(): void |
Delete this Relationship from the iModel. |
|
insert(): string |
Insert this Relationship into the iModel. |
|
toJSON(): RelationshipProps |
Obtain the JSON representation of this Entity. |
|
update(): void |
Update this Relationship in the iModel. |
|
getInstance<T extends Relationship>(iModel: IModelDb, criteria: string | SourceAndTarget): T Static |
|
|
onDeletedDependency(_props: RelationshipProps, _iModel: IModelDb): void Static |
Callback invoked by saveChanges on an ElementDrivesElement relationship when the relationship instance has been deleted. |
|
onRootChanged(_props: RelationshipProps, _iModel: IModelDb): void Static |
Callback invoked by saveChanges on an ElementDrivesElement relationship when its input has changed or is the output of some upstream relationship whose input has changed. |
|
Inherited methods
Name |
Inherited from |
Description |
collectReferenceIds(_referenceIds: EntityReferenceSet): void Protected Inherited |
Entity |
Collect the Ids of this entity's references at this level of the class hierarchy. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited |
Entity |
Call a function for each property of this Entity. |
getReferenceIds(): EntityReferenceSet Inherited |
Entity |
Get the set of this entity's entity references, EntityReferenceSet. |
is(otherClass: ): boolean Static Inherited |
Entity |
return whether this Entity class is a subclass of another Entity class |
Properties
Name |
Type |
Description |
|
className Accessor Static ReadOnly |
string |
The name of the BIS class associated with this class. |
|
sourceId Readonly |
string |
|
|
targetId Readonly |
string |
|
|
Inherited properties
Name |
Type |
Inherited from |
Description |
classFullName Accessor Inherited ReadOnly |
string |
Entity |
Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly |
string |
Entity |
Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly |
string |
Entity |
The name of the BIS class associated with this class. |
id Inherited |
string |
Entity |
The Id of this Entity. |
iModel Inherited |
IModelDb |
Entity |
The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited |
"true" |
Entity |
An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static Inherited |
|
Entity |
The Schema that defines this class. |
schemaName Accessor Inherited ReadOnly |
string |
Entity |
The name of the BIS Schema that defines this class |
Defined in
Last Updated: 14 November, 2024