GroupImpartsToMembers Class
Represents group membership where the group Element (and its properties) impart information about the member Elements above mere membership. Implies that properties of the group should be considered as properties of its members.
@note The associated ECClass was added to the BisCore schema in version 1.0.11
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: ElementGroupsMembersProps, iModel: IModelDb): GroupImpartsToMembers |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited | ElementGroupsMembers | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void Inherited | ElementGroupsMembers | Delete this Relationship from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited | ElementGroupsMembers | Call a function for each property of this Entity. |
getReferenceIds(): EntityReferenceSet Inherited | ElementGroupsMembers | Get the set of this entity's entity references, EntityReferenceSet. |
insert(): string Inherited | ElementGroupsMembers | Insert this Relationship into the iModel. |
toJSON(): RelationshipProps Inherited | ElementGroupsMembers | Obtain the JSON representation of this Entity. |
update(): void Inherited | ElementGroupsMembers | Update this Relationship in the iModel. |
create<T extends ElementRefersToElements>(iModel: IModelDb, sourceId: string, targetId: string, memberPriority: number0): T Static Inherited | ElementGroupsMembers | Create an instance of the Relationship. |
getInstance<T extends Relationship>(iModel: IModelDb, criteria: string | SourceAndTarget): T Static Inherited | ElementGroupsMembers | |
insert<T extends ElementRefersToElements>(iModel: IModelDb, sourceId: string, targetId: string): string Static Inherited | ElementGroupsMembers | Insert a new instance of the Relationship. |
is(otherClass: ): boolean Static Inherited | ElementGroupsMembers | return whether this Entity class is a subclass of another Entity class |
onDeletedDependency(_props: RelationshipProps, _iModel: IModelDb): void Static Inherited | ElementGroupsMembers | Callback invoked by saveChanges on an ElementDrivesElement relationship when the relationship instance has been deleted. |
onRootChanged(_props: RelationshipProps, _iModel: IModelDb): void Static Inherited | ElementGroupsMembers | Callback invoked by saveChanges on an ElementDrivesElement relationship when its input has changed or is the output of some upstream relationship whose input has changed. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Inherited ReadOnly | string | ElementGroupsMembers | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly | string | ElementGroupsMembers | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly | string | ElementGroupsMembers | The name of the BIS class associated with this class. |
id Inherited | string | ElementGroupsMembers | The Id of this Entity. |
iModel Inherited | IModelDb | ElementGroupsMembers | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited | "true" | ElementGroupsMembers | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
memberPriority Inherited | number | ElementGroupsMembers | |
schema Static Inherited | ElementGroupsMembers | The Schema that defines this class. | |
schemaName Accessor Inherited ReadOnly | string | ElementGroupsMembers | The name of the BIS Schema that defines this class |
sourceId Readonly Inherited | string | ElementGroupsMembers | |
targetId Readonly Inherited | string | ElementGroupsMembers |
Defined in
- core/backend/src/Relationship.ts Line 167
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.