create MethodStatic

Create a new SpatialCategory

create(iModelDb: IModelDb, definitionModelId: string, name: string): SpatialCategory

@returns The newly constructed SpatialCategory element.

@throws IModelError if unable to create the element.

Parameter Type Description
iModelDb IModelDb The iModel
definitionModelId string The DefinitionModel
name string The name/CodeValue of the SpatialCategory

Returns - SpatialCategory

The newly constructed SpatialCategory element.

Defined in

Last Updated: 13 September, 2024