tryGetElementProps Method
Get properties of an Element by Id, FederationGuid, or Code
tryGetElementProps<T extends ElementProps>(elementId: string | Code | ElementLoadProps): undefined | T
@returns The properties of the element or undefined
if the element is not found.
@throws IModelError if the element exists, but cannot be loaded.
@note Useful for cases when an element may or may not exist and throwing an Error
would be overkill.
@see IModelDb.Elements.getElementProps
Parameter | Type | Description |
---|---|---|
elementId | string | Code | ElementLoadProps |
Returns - undefined | T
The properties of the element or undefined
if the element is not found.
Defined in
- core/backend/src/IModelDb.ts Line 1784
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.