insertAspect Method
Insert a new ElementAspect into the iModel.
insertAspect(aspectProps: ElementAspectProps): string
@throws IModelError if unable to insert the ElementAspect.
@returns the id of the newly inserted aspect.
@note Aspect Ids may collide with element Ids, so don't put both in a container like Set or Map use EntityReference for that instead.
Parameter | Type | Description |
---|---|---|
aspectProps | ElementAspectProps | The properties of the new ElementAspect. |
Returns - string
the id of the newly inserted aspect.
Defined in
- core/backend/src/IModelDb.ts Line 2217
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.