ExportGraphicsMeshVisitor Class
- Iterator to walk the facets of an ExportGraphicsMesh and present them to the world as if visiting a Polyface.
- Because the ExportGraphicsMesh has limited data:
- There is no auxData in this visitor.
- There is no color in this visitor.
- All edgeVisible are true.
Extends
Implements
Methods
Name | Description | |
---|---|---|
clearArrays(): void | clear the contents of all arrays. | |
clientAuxIndex(_i: number): number | Return the aux data index of vertex i within the currently loaded facet | |
clientColorIndex(_i: number): number | Return the color index of vertex i within the currently loaded facet | |
clientNormalIndex(i: number): number | Return the normal index of vertex i within the currently loaded facet. | |
clientParamIndex(i: number): number | Return the param index of vertex i within the currently loaded facet. | |
clientPointIndex(i: number): number | Return the point index of vertex i within the currently loaded facet | |
clientPolyface(): Polyface | return the client polyface | |
currentReadIndex(): number | Return the index (in the client polyface) of the current facet | |
moveToNextFacet(): boolean | Load data for the next facet. | |
moveToReadIndex(facetIndex: number): boolean | Select a facet by simple index. | |
pushDataFrom(other: PolyfaceVisitor, index: number): void | transfer data from a specified index of the other visitor as new data in this visitor. | |
pushInterpolatedDataFrom(other: PolyfaceVisitor, index0: number, fraction: number, index1: number): void | transfer interpolated data from the other visitor. | |
reset(): void | Reset the iterator to start at the first facet of the polyface. | |
setNumWrap(numWrap: number): void | Set the number of vertices to replicate in visitor arrays. | |
create(polyface: ExportGraphicsMesh, numWrap: number): ExportGraphicsMeshVisitor Static | Create a visitor for iterating the facets of polyface , with indicated number of points to be added to each facet to produce closed point arrays |
Defined in
- core/backend/src/ExportGraphics.ts Line 335
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.