ExportGraphicsMesh Interface
A triangulated mesh with unified indices, suitable for direct use with graphics APIs.
See IModelDb.exportGraphics
Properties
Name |
Type |
Description |
|
indices |
Int32Array |
Zero-based vertex indices, every three indices represent a triangle |
|
isTwoSided |
boolean |
If true, clients should assume both sides of the mesh are visible and not cull backfaces. |
|
normals |
Float32Array |
Normals for this mesh, laid out in the pattern XYZXYZ |
|
params |
Float32Array |
Parameters (uvs) for this mesh, laid out in the pattern XYXY |
|
points |
Float64Array |
Vertices for this mesh, laid out in the pattern XYZXYZ |
|
Defined in
Last Updated: 14 November, 2024