PhysicalElementFulfillsFunction Class
Relates a PhysicalElement to the FunctionalElement elements that it fulfills.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: RelationshipProps, iModel: IModelDb): PhysicalElementFulfillsFunction Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited | ElementRefersToElements | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void Inherited | ElementRefersToElements | Delete this Relationship from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited | ElementRefersToElements | Call a function for each property of this Entity. |
getReferenceIds(): EntityReferenceSet Inherited | ElementRefersToElements | Get the set of this entity's entity references, EntityReferenceSet. |
insert(): string Inherited | ElementRefersToElements | Insert this Relationship into the iModel. |
toJSON(): RelationshipProps Inherited | ElementRefersToElements | Obtain the JSON representation of this Entity. |
update(): void Inherited | ElementRefersToElements | Update this Relationship in the iModel. |
create<T extends ElementRefersToElements>(iModel: IModelDb, sourceId: string, targetId: string): T Static Inherited | ElementRefersToElements | Create an instance of the Relationship. |
getInstance<T extends Relationship>(iModel: IModelDb, criteria: string | SourceAndTarget): T Static Inherited | ElementRefersToElements | |
insert<T extends ElementRefersToElements>(iModel: IModelDb, sourceId: string, targetId: string): string Static Inherited | ElementRefersToElements | Insert a new instance of the Relationship. |
is(otherClass: ): boolean Static Inherited | ElementRefersToElements | return whether this Entity class is a subclass of another Entity class |
onDeletedDependency(_props: RelationshipProps, _iModel: IModelDb): void Static Inherited | ElementRefersToElements | Callback invoked by saveChanges on an ElementDrivesElement relationship when the relationship instance has been deleted. |
onRootChanged(_props: RelationshipProps, _iModel: IModelDb): void Static Inherited | ElementRefersToElements | Callback invoked by saveChanges on an ElementDrivesElement relationship when its input has changed or is the output of some upstream relationship whose input has changed. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Inherited ReadOnly | string | ElementRefersToElements | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly | string | ElementRefersToElements | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly | string | ElementRefersToElements | The name of the BIS class associated with this class. |
id Inherited | string | ElementRefersToElements | The Id of this Entity. |
iModel Inherited | IModelDb | ElementRefersToElements | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited | "true" | ElementRefersToElements | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static Inherited | ElementRefersToElements | The Schema that defines this class. | |
schemaName Accessor Inherited ReadOnly | string | ElementRefersToElements | The name of the BIS Schema that defines this class |
sourceId Readonly Inherited | string | ElementRefersToElements | |
targetId Readonly Inherited | string | ElementRefersToElements |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.