DrawingGraphicRepresentsFunctionalElement Class
Relates a DrawingGraphic to the FunctionalElement that it represents
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: RelationshipProps, iModel: IModelDb): DrawingGraphicRepresentsFunctionalElement Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited | DrawingGraphicRepresentsElement | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void Inherited | DrawingGraphicRepresentsElement | Delete this Relationship from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited | DrawingGraphicRepresentsElement | Call a function for each property of this Entity. |
getReferenceIds(): EntityReferenceSet Inherited | DrawingGraphicRepresentsElement | Get the set of this entity's entity references, EntityReferenceSet. |
insert(): string Inherited | DrawingGraphicRepresentsElement | Insert this Relationship into the iModel. |
toJSON(): RelationshipProps Inherited | DrawingGraphicRepresentsElement | Obtain the JSON representation of this Entity. |
update(): void Inherited | DrawingGraphicRepresentsElement | Update this Relationship in the iModel. |
create<T extends ElementRefersToElements>(iModel: IModelDb, sourceId: string, targetId: string): T Static Inherited | DrawingGraphicRepresentsElement | Create an instance of the Relationship. |
getInstance<T extends Relationship>(iModel: IModelDb, criteria: string | SourceAndTarget): T Static Inherited | DrawingGraphicRepresentsElement | |
insert<T extends ElementRefersToElements>(iModel: IModelDb, sourceId: string, targetId: string): string Static Inherited | DrawingGraphicRepresentsElement | Insert a new instance of the Relationship. |
is(otherClass: ): boolean Static Inherited | DrawingGraphicRepresentsElement | return whether this Entity class is a subclass of another Entity class |
onDeletedDependency(_props: RelationshipProps, _iModel: IModelDb): void Static Inherited | DrawingGraphicRepresentsElement | Callback invoked by saveChanges on an ElementDrivesElement relationship when the relationship instance has been deleted. |
onRootChanged(_props: RelationshipProps, _iModel: IModelDb): void Static Inherited | DrawingGraphicRepresentsElement | Callback invoked by saveChanges on an ElementDrivesElement relationship when its input has changed or is the output of some upstream relationship whose input has changed. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Inherited ReadOnly | string | DrawingGraphicRepresentsElement | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly | string | DrawingGraphicRepresentsElement | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly | string | DrawingGraphicRepresentsElement | The name of the BIS class associated with this class. |
id Inherited | string | DrawingGraphicRepresentsElement | The Id of this Entity. |
iModel Inherited | IModelDb | DrawingGraphicRepresentsElement | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited | "true" | DrawingGraphicRepresentsElement | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static Inherited | DrawingGraphicRepresentsElement | The Schema that defines this class. | |
schemaName Accessor Inherited ReadOnly | string | DrawingGraphicRepresentsElement | The name of the BIS Schema that defines this class |
sourceId Readonly Inherited | string | DrawingGraphicRepresentsElement | |
targetId Readonly Inherited | string | DrawingGraphicRepresentsElement |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.